summaryrefslogtreecommitdiffstats
path: root/tdefile-plugins/exr/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tdefile-plugins/exr/Makefile.am')
-rw-r--r--tdefile-plugins/exr/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/tdefile-plugins/exr/Makefile.am b/tdefile-plugins/exr/Makefile.am
new file mode 100644
index 00000000..8df4ed64
--- /dev/null
+++ b/tdefile-plugins/exr/Makefile.am
@@ -0,0 +1,25 @@
+## Makefile.am for EXR file meta info plugin
+
+KDE_CXXFLAGS = $(USE_EXCEPTIONS)
+
+# set the include path for X, qt and KDE
+INCLUDES = -Drestrict= $(all_includes) $(EXR_FLAGS)
+# INCLUDES = $(all_includes) $(EXR_FLAGS)
+
+# these are the headers for your project
+noinst_HEADERS = tdefile_exr.h
+
+kde_module_LTLIBRARIES = tdefile_exr.la
+
+tdefile_exr_la_SOURCES = tdefile_exr.cpp
+tdefile_exr_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+tdefile_exr_la_LIBADD = $(LIB_KIO) $(LIB_EXR)
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/tdefile_exr.pot
+
+services_DATA = tdefile_exr.desktop
+servicesdir = $(kde_servicesdir)