summaryrefslogtreecommitdiffstats
path: root/tdefile-plugins/tiff/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tdefile-plugins/tiff/Makefile.am')
-rw-r--r--tdefile-plugins/tiff/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/tdefile-plugins/tiff/Makefile.am b/tdefile-plugins/tiff/Makefile.am
new file mode 100644
index 00000000..9807a66c
--- /dev/null
+++ b/tdefile-plugins/tiff/Makefile.am
@@ -0,0 +1,21 @@
+## Makefile.am for Tiff file meta info plugin
+
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes)
+
+noinst_HEADERS = tdefile_tiff.h
+
+kde_module_LTLIBRARIES = tdefile_tiff.la
+
+tdefile_tiff_la_SOURCES = tdefile_tiff.cpp
+tdefile_tiff_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+tdefile_tiff_la_LIBADD = $(LIB_KIO) $(LIBTIFF)
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/tdefile_tiff.pot
+
+services_DATA = tdefile_tiff.desktop
+servicesdir = $(kde_servicesdir)