summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules37
1 files changed, 37 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..b0cae30
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,37 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/kde3/include/kde
+DEB_CONFIGURE_MANDIR := /opt/kde3/share/man
+DEB_CONFIGURE_PREFIX := /opt/kde3
+DEB_CONFIGURE_INFODIR := /opt/kde3/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_COMPRESS_EXCLUDE=.docbook
+DEB_SCONS_PREFIX=/opt/kde3
+
+CONFIG_STATUS=$(DEB_BUILDDIR)/config.status
+SCONS_CMD=/usr/bin/scons
+
+common-configure-arch common-configure-indep:: common-configure-impl
+common-configure-impl:: $(CONFIG_STATUS)
+$(CONFIG_STATUS):
+ env PATH=/opt/kde3/bin:$(PATH) $(SCONS_CMD) configure prefix=$(DEB_DESTDIR)$(DEB_SCONS_PREFIX)
+ touch $(CONFIG_STATUS)
+
+common-build-arch common-build-indep:: common-build-impl
+common-build-impl::
+ env PATH=/opt/kde3/bin:$(PATH) $(SCONS_CMD)
+ rm -f doc/en/index.cache.bz2
+
+common-install-arch common-install-indep:: common-install-impl
+common-install-impl::
+ env PATH=/opt/kde3/bin:$(PATH) $(SCONS_CMD) install
+
+clean::
+ rm -rf build cache scons-mini
+ rm -f admin/*.pyc $(CONFIG_STATUS)
+
+DEB_INSTALL_DOCS_kio-locate-kde3 := -XREADME -XNEWS -XTODO -XAUTHORS