summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-29 17:16:10 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-29 17:16:10 +0200
commit21a4c9fd75710b3c59ce6c601b5686831ecbc25c (patch)
treeff2865ae44efa47f2f2e5baf39ad055ba1b91e4e /CMakeLists.txt
parentdf8c61744d2ef0fd748e383b79fb1fa3fa7caca6 (diff)
downloadtdeio-umountwrapper-21a4c9fd75710b3c59ce6c601b5686831ecbc25c.tar.gz
tdeio-umountwrapper-21a4c9fd75710b3c59ce6c601b5686831ecbc25c.zip
Use common rules for build and install translations.
Change CMake project name to tdeio_umountwrapper. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1cc4d5d..d28e466 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,7 +12,7 @@ cmake_minimum_required( VERSION 2.8.12 )
#### general package setup
-project( tdeio-umountwrapper )
+project( tdeio_umountwrapper )
set( VERSION R14.1.0 )
@@ -67,7 +67,11 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
tde_conditional_add_subdirectory( BUILD_ALL src )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+
+
+##### other data ################################
+
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
##### write configure files