summaryrefslogtreecommitdiffstats
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2018-12-13 03:29:22 +0100
committerSlávek Banko <slavek.banko@axis.cz>2018-12-13 03:29:41 +0100
commit7422af7c1fb9accde0b1880b4eb6a58e2244b6ce (patch)
treeb69bde64c55562d1a21507a52a23df1b45836f15 /po/CMakeLists.txt
parent320de726f9e2cbb4a7fcf0265861eef30bb33df4 (diff)
downloadtdeio-umountwrapper-7422af7c1fb9accde0b1880b4eb6a58e2244b6ce.tar.gz
tdeio-umountwrapper-7422af7c1fb9accde0b1880b4eb6a58e2244b6ce.zip
Add CMakeL10n rules.
Create translation template. Add CMake rules to build translations. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit ce24f7e8bee0d70bdebe4e979eaefdb56c1b3ebb)
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
new file mode 100644
index 0000000..1007122
--- /dev/null
+++ b/po/CMakeLists.txt
@@ -0,0 +1,6 @@
+# build translations if some are already available
+
+file( GLOB _srcs RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
+if( _srcs )
+ tde_create_translation( LANG auto OUTPUT_NAME tdeio_umountwrapper )
+endif( )