summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2014-01-21 09:42:10 +0100
committerSlávek Banko <slavek.banko@axis.cz>2014-01-21 09:42:10 +0100
commit62ac96e110e21c0289e890b6e2a824b61d5cb055 (patch)
tree3c99571168c736eb72060c63940b27a121a25134 /CMakeLists.txt
parent8151a7080181fe5b79fb3ce5dfd2dc2830f15b17 (diff)
downloadtdelibs-62ac96e110e21c0289e890b6e2a824b61d5cb055.tar.gz
tdelibs-62ac96e110e21c0289e890b6e2a824b61d5cb055.zip
Fix tdecore directories of linked libraries
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 51ddfc9b4..6242410d4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -46,6 +46,8 @@ tde_setup_paths( )
tde_setup_architecture_flags( )
find_package( TQt )
+list( APPEND TDECORE_LIBRARY_DIRS ${TQT_LIBRARY_DIRS} )
+
##### add apidox targets ############
@@ -618,6 +620,7 @@ endif( WITH_XRANDR )
pkg_search_module( XRENDER xrender )
if( XRENDER_FOUND )
set( HAVE_XRENDER 1 )
+ list( APPEND TDECORE_LIBRARY_DIRS ${XRENDER_LIBRARY_DIRS} )
else( XRENDER_FOUND)
message(FATAL_ERROR "\nxrender support is required, but not found on your system" )
endif( XRENDER_FOUND )
@@ -713,6 +716,7 @@ if( WITH_LIBART )
message(FATAL_ERROR "\nlibart-2.0 support are requested, but not found on your system" )
endif( NOT LIBART_FOUND )
set( HAVE_LIBART 1 )
+ list( APPEND TDECORE_LIBRARY_DIRS ${LIBART_LIBRARY_DIRS} )
endif( WITH_LIBART )
@@ -727,6 +731,7 @@ if( WITH_LIBIDN )
check_include_file( "idna.h" HAVE_IDNA_H )
check_include_file( "punycode.h" HAVE_PUNYCODE_H )
check_include_file( "stringprep.h" HAVE_STRINGPREP_H )
+ list( APPEND TDECORE_LIBRARY_DIRS ${LIBIDN_LIBRARY_DIRS} )
endif( WITH_LIBIDN )
##### check for libbfq ##########################
@@ -865,6 +870,7 @@ if( DBUS_TQT_FOUND )
else()
tde_message_fatal( "dbus-1-tqt are required, but not found on your system" )
endif( )
+list( APPEND TDECORE_LIBRARY_DIRS ${DBUS_TQT_LIBRARY_DIRS} )
if( WITH_NETWORK_MANAGER_BACKEND )
@@ -925,6 +931,7 @@ if( WITH_GAMIN )
pkg_search_module( GAMIN gamin )
if( GAMIN_FOUND )
set( HAVE_FAM 1 )
+ list( APPEND TDECORE_LIBRARY_DIRS ${GAMIN_LIBRARY_DIRS} )
else( GAMIN_FOUND )
message(FATAL_ERROR "\nfam/gamin support was requested, but gamin was not found on your system" )
endif( GAMIN_FOUND )