summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFrançois Andriot <francois.andriot@free.fr>2014-10-05 14:44:34 +0200
committerSlávek Banko <slavek.banko@axis.cz>2014-10-05 14:45:13 +0200
commitaf2c2afb25ce2b62767cdc639cf6d0c4fb967eaa (patch)
tree39ac29925ab8237f14f3597b0079c94ed25de922 /CMakeLists.txt
parent67d3c303f3ba902ebc8337d683cc184340d5db32 (diff)
downloadtdelibs-af2c2afb25ce2b62767cdc639cf6d0c4fb967eaa.tar.gz
tdelibs-af2c2afb25ce2b62767cdc639cf6d0c4fb967eaa.zip
Fix hardcoded link flag to "dl" library
Fix "dlopen" function detection
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 9 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7ee04b5c6..5433fe121 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -475,10 +475,15 @@ set( kde_socklen_t socklen_t )
##### check for libdl ###########################
-find_library( HAVE_LIBDL dl )
-if( NOT HAVE_LIBDL-NOTFOUND )
- set( DL_LIBRARIES dl )
-endif( NOT HAVE_LIBDL-NOTFOUND )
+set( DL_LIBRARIES dl )
+check_library_exists( ${DL_LIBRARIES} dlopen /lib HAVE_LIBDL )
+if( NOT HAVE_LIBDL )
+ unset( DL_LIBRARIES )
+ check_function_exists( dlopen HAVE_DLOPEN )
+ if( HAVE_DLOPEN )
+ set( HAVE_LIBDL 1 )
+ endif( HAVE_DLOPEN )
+endif( NOT HAVE_LIBDL )
##### check for utempter ########################