summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2015-04-05 19:13:40 +0200
committerSlávek Banko <slavek.banko@axis.cz>2015-04-05 19:16:28 +0200
commitc80f418abf9c3061b0fb7759a1e560a0ab1243fe (patch)
tree7a7ae0efdad515110b462950424fd78dd9651154 /CMakeLists.txt
parent3e23bfa58d9488d44099dffd4b05bc456ae28022 (diff)
downloadtdelibs-c80f418abf9c3061b0fb7759a1e560a0ab1243fe.tar.gz
tdelibs-c80f418abf9c3061b0fb7759a1e560a0ab1243fe.zip
Fix xext configure check for CMake build
This resolves Bug 2410 Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 9 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f43dcb746..8916b74e5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -690,6 +690,7 @@ else( XRENDER_FOUND)
message(FATAL_ERROR "\nxrender support is required, but not found on your system" )
endif( XRENDER_FOUND )
+
##### check for xcomposite #########################
if( WITH_XCOMPOSITE )
@@ -699,13 +700,18 @@ if( WITH_XCOMPOSITE )
else( WITH_XCOMPOSITE )
tde_message_fatal( "xcomposite support was requested, but xcomposite was not found on your system" )
endif( XCOMPOSITE_FOUND )
+endif( WITH_XCOMPOSITE )
+
- # xext (tderandr, tdestyles/keramik, tdeui)
+##### check for xext ###############################
+
+if( HAVE_XRENDER OR WITH_XCOMPOSITE OR WITH_XRANDR OR HAVE_X11_EXTENSIONS_SHAPE_H )
+ # xext (tdecore, tdeui, tderandr, tdestyles/keramik)
pkg_search_module( XEXT xext )
if( NOT XEXT_FOUND )
- tde_message_fatal( "xext is required for xcomposite support, but was not found on your system" )
+ tde_message_fatal( "xext is required, but was not found on your system" )
endif( )
-endif( WITH_XCOMPOSITE )
+endif( HAVE_XRENDER OR WITH_XCOMPOSITE OR WITH_XRANDR OR HAVE_X11_EXTENSIONS_SHAPE_H )
##### check for libxml-2.0 ######################