summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2015-09-14 03:54:16 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2015-09-14 03:54:16 -0500
commitffa54887cef6a8e36b2d63e7e9139ac11863a525 (patch)
treea36d7ade29b74464af1f87e61e8cbc05441dd64b /CMakeLists.txt
parent4238dc9cea6c543abf993d3a28af564f1c8dea0c (diff)
downloadtdelibs-ffa54887cef6a8e36b2d63e7e9139ac11863a525.tar.gz
tdelibs-ffa54887cef6a8e36b2d63e7e9139ac11863a525.zip
Add additional cryptographic card functions to tdehwlib
Fix FTBFS on old distributions
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 96b72e0b6..4621f92f5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -696,6 +696,15 @@ if( WITH_CRYPTSETUP )
message(FATAL_ERROR "\ncryptsetup support was requested, but libcryptsetup was not found on your system" )
endif( NOT LIBCRYPTSETUP_FOUND )
set( HAVE_CRYPTSETUP 1 )
+ if ( HAVE_CRYPTSETUP )
+ check_c_source_compiles("
+ #include <libcryptsetup.h>
+ int main(int argc, char *argv[]) { crypt_keyslot_info status = CRYPT_SLOT_INVALID; return 0; } "
+ HAVE_NEW_CRYPTSETUP )
+ endif( )
+ if ( NOT HAVE_NEW_CRYPTSETUP )
+ set( CRYPTSETUP_OLD_API 1 )
+ endif( )
endif( )