summaryrefslogtreecommitdiffstats
path: root/kstyles/asteroid/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-08-01 19:56:15 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-08-01 19:56:15 +0000
commit102d191fa7d143d634d35ca894945688a196361b (patch)
treee76c3f63d2bcdb67a80957fee6251dff6d32bad5 /kstyles/asteroid/Makefile.am
parentf0b1722fbfca15e4b9c0afec6d0191466b719417 (diff)
downloadtdelibs-102d191fa7d143d634d35ca894945688a196361b.tar.gz
tdelibs-102d191fa7d143d634d35ca894945688a196361b.zip
Add Asteroid widget theme to kdelibs
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdelibs@1244309 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kstyles/asteroid/Makefile.am')
-rw-r--r--kstyles/asteroid/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/kstyles/asteroid/Makefile.am b/kstyles/asteroid/Makefile.am
new file mode 100644
index 000000000..5ce2bf321
--- /dev/null
+++ b/kstyles/asteroid/Makefile.am
@@ -0,0 +1,18 @@
+# Yaaay poorly-documented hackish magical software!
+# (re: autoconf and automake and friends,
+# not my own software, of course) -clee
+
+AM_CPPFLAGS = -DQT_PLUGIN
+METASOURCES = AUTO
+
+INCLUDES = $(all_includes)
+
+noinst_HEADERS = asteroid.h
+kde_style_LTLIBRARIES = asteroid.la
+
+asteroid_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -module
+asteroid_la_LIBADD = -lkdefx
+asteroid_la_SOURCES = asteroid.cpp
+
+themercdir = $(kde_datadir)/kstyle/themes
+themerc_DATA = asteroid.themerc