summaryrefslogtreecommitdiffstats
path: root/tdecert/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:21 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:21 -0600
commitdfe289850f068f19ba4a83ab4e7e22a7e09c13c9 (patch)
treec297348a55df66c571de4525646e0b9762427353 /tdecert/Makefile.am
parentb7658a0d5eca24a9d37c6e04f88298ef02389db0 (diff)
downloadtdelibs-dfe289850f068f19ba4a83ab4e7e22a7e09c13c9.tar.gz
tdelibs-dfe289850f068f19ba4a83ab4e7e22a7e09c13c9.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdecert/Makefile.am')
-rw-r--r--tdecert/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/tdecert/Makefile.am b/tdecert/Makefile.am
new file mode 100644
index 000000000..d43ce0f5b
--- /dev/null
+++ b/tdecert/Makefile.am
@@ -0,0 +1,18 @@
+INCLUDES= -I$(top_srcdir)/kio/kssl -I$(top_builddir)/kio/kssl -I$(top_srcdir) $(SSL_INCLUDES) $(all_includes)
+
+kde_module_LTLIBRARIES = libtdecertpart.la
+
+libtdecertpart_la_SOURCES = tdecertpart.cc
+
+libtdecertpart_la_LDFLAGS = $(KDE_PLUGIN) $(all_libraries)
+libtdecertpart_la_LIBADD = $(LIB_KPARTS) $(LIB_QT) $(LIB_TDEUI) $(LIB_KFILE) $(LIB_TDECORE)
+libtdecertpart_la_DEPENDENCIES = $(LIB_KPARTS)
+
+libtdecertpart_la_METASOURCES = AUTO
+
+servicedir = $(kde_servicesdir)
+service_DATA = tdecertpart.desktop
+
+rcdir = $(kde_datadir)/tdecertpart
+rc_DATA = tdecertpart.rc
+