summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt223
1 files changed, 142 insertions, 81 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1c06eea4a..631e7a5a7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,7 +9,12 @@
#
#################################################
-cmake_minimum_required( VERSION 2.8.12 )
+
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
##### general package setup #####################
@@ -17,13 +22,13 @@ cmake_minimum_required( VERSION 2.8.12 )
project( tdelibs )
set( PACKAGE tdelibs )
-set( VERSION R14.1.0 )
##### include essential cmake modules ###########
include( FindPkgConfig )
include( CheckIncludeFile )
+include( CheckIncludeFiles )
include( CheckSymbolExists )
include( CheckFunctionExists )
include( CheckCSourceCompiles )
@@ -31,11 +36,11 @@ include( CheckCXXSourceCompiles )
include( CheckTypeSize )
include( CheckCSourceRuns )
include( CheckLibraryExists )
+include( CheckStructHasMember )
##### include our cmake modules #################
-set( CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules" )
include( TDEMacros )
include( TDESetupPaths )
@@ -52,69 +57,90 @@ list( APPEND TDECORE_LIBRARY_DIRS ${TQT_LIBRARY_DIRS} )
##### add apidox targets ############
-add_custom_target(apidox
- COMMAND "./generate_apidox" "${CMAKE_SOURCE_DIR}" "${CMAKE_BINARY_DIR}" "${HTML_INSTALL_DIR}" "/usr/share/tqt3/doc/html"
- WORKING_DIRECTORY "${CMAKE_SOURCE_DIR}/cmake/")
+add_custom_target( apidox
+ COMMAND ${CMAKE_COMMAND} -E env
+ "TQTDOCDIR=/usr/share/tqt3/doc/html"
+ ${CMAKE_SOURCE_DIR}/admin/doxygen.sh
+ --no-modulename
+ ${CMAKE_SOURCE_DIR}
+ COMMAND
+ find ${CMAKE_BINARY_DIR}/apidocs -name '*.html' |
+ xargs -r sed -i 's|${CMAKE_BINARY_DIR}/apidocs|${HTML_INSTALL_DIR}/en/${PROJECT_NAME}-apidocs|g'
+ COMMAND
+ find ${CMAKE_BINARY_DIR}/apidocs -name '*.tag' |
+ xargs -r sed -i 's|${CMAKE_SOURCE_DIR}/|${PROJECT_NAME}/|g'
+ WORKING_DIRECTORY ${CMAKE_BINARY_DIR}
+)
+
+add_custom_target( install-apidox
+ COMMAND ${CMAKE_COMMAND} -E echo Apidox installed in ${HTML_INSTALL_DIR}/en/${PROJECT_NAME}-apidocs
+)
-add_custom_target(install-apidox
- COMMAND "./install_apidox" "${CMAKE_SOURCE_DIR}" "${CMAKE_BINARY_DIR}" "${HTML_INSTALL_DIR}" "${CMAKE_INSTALL_PREFIX}"
- WORKING_DIRECTORY "${CMAKE_SOURCE_DIR}/cmake/")
+install( CODE "
+ if( EXISTS ${CMAKE_BINARY_DIR}/apidocs )
+ file(
+ INSTALL ${CMAKE_BINARY_DIR}/apidocs/
+ DESTINATION ${HTML_INSTALL_DIR}/en/${PROJECT_NAME}-apidocs
+ PATTERN doxygen_sqlite3.db EXCLUDE
+ PATTERN installdox-slow EXCLUDE
+ )
+ endif()"
+)
##### user requested OPTIONs ####################
-OPTION( WITH_ALL_OPTIONS "Enable all OPTIONal support" OFF )
-
-OPTION( TDE_MALLOC "Use own malloc implementation" OFF )
-OPTION( TDE_MALLOC_DEBUG "Enable debugging in fast malloc" OFF )
-OPTION( TDE_MALLOC_FULL "Make alloc as fast as possible" OFF )
-
-OPTION( WITH_ARTS "Build with aRts" ON )
-OPTION( WITH_ALSA "Enable ALSA support" ON )
-OPTION( WITH_LIBART "Enable libart support (for SVG icons)" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_LIBIDN "Enable support for libidn" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_SSL "Enable support for SSL" ON )
-OPTION( WITH_CUPS "Enable CUPS support" ON )
-OPTION( WITH_IMAGETOPS_BINARY "Enable installation of imagetops binary" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_LUA "Enable LUA support" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_TIFF "Enable tiff support" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_JASPER "Enable jasper (jpeg2k) support" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_OPENEXR "Enable openexr support" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_UTEMPTER "Use utempter for utmp management" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_AVAHI "Enable AVAHI support" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_ELFICON "Enable ELF embedded icon support" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_PCRE "Enable pcre regex support for kjs" ON )
-OPTION( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_INOTIFY "Enable inotify support for tdeio" ON )
-OPTION( WITH_GAMIN "Enable FAM/GAMIN support" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_TDEHWLIB "Enable TDE hwlib globally" ON )
-OPTION( WITH_TDEHWLIB_DAEMONS "Enable daemons for TDE hwlib" ${WITH_TDEHWLIB} )
-OPTION( WITH_HAL "Enable HAL support" OFF )
-OPTION( WITH_DEVKITPOWER "Enable DeviceKit Power support" OFF )
-OPTION( WITH_LOGINDPOWER "Enable Logind/Systemd Power support" OFF )
-OPTION( WITH_UPOWER "Enable uPower support" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_UDISKS "Enable uDisks support" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_UDISKS2 "Enable uDisks2 support" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_UDEVIL "Enable udevil support" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_CONSOLEKIT "Enable ConsoleKit support" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_NETWORK_MANAGER_BACKEND "Enable network-manager support" OFF )
-OPTION( WITH_SUDO_TDESU_BACKEND "Use sudo as backend for tdesu (default is su)" OFF )
-OPTION( WITH_OLD_XDG_STD "Use the pre R14.0.0 XDG standard where both TDE and KDE are recognized in desktop files" OFF )
-OPTION( WITH_PCSC "Enable PC/SC SmartCard support" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_PKCS "Enable PKCS support" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_CRYPTSETUP "Enable cryptsetup support" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_LZMA "Enable support for LZMA/XZ" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_LIBBFD "Enable pretty backtraces with libbfd from GNU binutils" OFF )
-OPTION( WITH_XRANDR "Build the tderandr library" ON )
-OPTION( WITH_XCOMPOSITE "Enable xcomposite support" ON )
-OPTION( WITH_MITSHM "Use MIT-SHM for pixmap loading/saving" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_KDE4_MENU_SUFFIX "Add [KDE4] tag to KDE4 menu items" OFF )
-
-OPTION( WITH_ISPELL "Enable ispell support" ON )
-OPTION( WITH_ASPELL "Enable aspell support" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_HSPELL "Enable hspell support" ${WITH_ALL_OPTIONS} )
-
-OPTION( WITH_TDEICONLOADER_DEBUG "Enable debugging in TDEIconLoader class" OFF )
+option( WITH_ALL_OPTIONS "Enable all OPTIONal support" OFF )
+
+option( TDE_MALLOC "Use own malloc implementation" OFF )
+option( TDE_MALLOC_DEBUG "Enable debugging in fast malloc" OFF )
+option( TDE_MALLOC_FULL "Make alloc as fast as possible" OFF )
+
+option( WITH_ARTS "Build with aRts" ON )
+option( WITH_ALSA "Enable ALSA support" ON )
+option( WITH_LIBART "Enable libart support (for SVG icons)" ${WITH_ALL_OPTIONS} )
+option( WITH_LIBIDN "Enable support for libidn" ${WITH_ALL_OPTIONS} )
+option( WITH_SSL "Enable support for SSL" ON )
+option( WITH_CUPS "Enable CUPS support" ON )
+option( WITH_IMAGETOPS_BINARY "Enable installation of imagetops binary" ${WITH_ALL_OPTIONS} )
+option( WITH_LUA "Enable LUA support" ${WITH_ALL_OPTIONS} )
+option( WITH_TIFF "Enable tiff support" ${WITH_ALL_OPTIONS} )
+option( WITH_JASPER "Enable jasper (jpeg2k) support" ${WITH_ALL_OPTIONS} )
+option( WITH_OPENEXR "Enable openexr support" ${WITH_ALL_OPTIONS} )
+option( WITH_UTEMPTER "Use utempter for utmp management" ${WITH_ALL_OPTIONS} )
+option( WITH_AVAHI "Enable AVAHI support" ${WITH_ALL_OPTIONS} )
+option( WITH_ELFICON "Enable ELF embedded icon support" ${WITH_ALL_OPTIONS} )
+option( WITH_PCRE "Enable pcre regex support for kjs" ON )
+option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+option( WITH_INOTIFY "Enable inotify support for tdeio" ON )
+option( WITH_GAMIN "Enable FAM/GAMIN support" ${WITH_ALL_OPTIONS} )
+option( WITH_TDEHWLIB "Enable TDE hwlib globally" ON )
+option( WITH_TDEHWLIB_DAEMONS "Enable daemons for TDE hwlib" ${WITH_TDEHWLIB} )
+option( WITH_DEVKITPOWER "Enable DeviceKit Power support" OFF )
+option( WITH_LOGINDPOWER "Enable Logind/Systemd Power support" OFF )
+option( WITH_UPOWER "Enable uPower support" ${WITH_ALL_OPTIONS} )
+option( WITH_UDISKS "Enable uDisks support" ${WITH_ALL_OPTIONS} )
+option( WITH_UDISKS2 "Enable uDisks2 support" ${WITH_ALL_OPTIONS} )
+option( WITH_UDEVIL "Enable udevil support" ${WITH_ALL_OPTIONS} )
+option( WITH_CONSOLEKIT "Enable ConsoleKit support" ${WITH_ALL_OPTIONS} )
+option( WITH_NETWORK_MANAGER_BACKEND "Enable network-manager support" OFF )
+option( WITH_SUDO_TDESU_BACKEND "Use sudo as backend for tdesu (default is su)" OFF )
+option( WITH_OLD_XDG_STD "Use the pre R14.0.0 XDG standard where both TDE and KDE are recognized in desktop files" OFF )
+option( WITH_PCSC "Enable PC/SC SmartCard support" ${WITH_ALL_OPTIONS} )
+option( WITH_PKCS "Enable PKCS support" ${WITH_ALL_OPTIONS} )
+option( WITH_CRYPTSETUP "Enable cryptsetup support" ${WITH_ALL_OPTIONS} )
+option( WITH_LZMA "Enable support for LZMA/XZ" ${WITH_ALL_OPTIONS} )
+option( WITH_LIBBFD "Enable pretty backtraces with libbfd from GNU binutils" OFF )
+option( WITH_XRANDR "Build the tderandr library" ON )
+option( WITH_XCOMPOSITE "Enable xcomposite support" ON )
+option( WITH_MITSHM "Use MIT-SHM for pixmap loading/saving" ${WITH_ALL_OPTIONS} )
+option( WITH_KDE4_MENU_SUFFIX "Add [KDE4] tag to KDE4 menu items" OFF )
+
+option( WITH_ISPELL "Enable ispell support" ON )
+option( WITH_ASPELL "Enable aspell support" ${WITH_ALL_OPTIONS} )
+option( WITH_HSPELL "Enable hspell support" ${WITH_ALL_OPTIONS} )
+
+option( WITH_TDEICONLOADER_DEBUG "Enable debugging in TDEIconLoader class" OFF )
##### set PKG_CONFIG_PATH #######################
@@ -194,6 +220,7 @@ check_include_file( "dirent.h" HAVE_DIRENT_H )
check_include_file( "dld.h" HAVE_DLD_H )
check_include_file( "dlfcn.h" HAVE_DLFCN_H )
check_include_file( "dl.h" HAVE_DL_H )
+check_include_files( "sys/types.h;sys/dl.h" HAVE_SYS_DL_H )
check_include_file( "float.h" HAVE_FLOAT_H )
check_include_file( "fstab.h" HAVE_FSTAB_H )
check_include_file( "ieeefp.h" HAVE_IEEEFP_H )
@@ -206,6 +233,7 @@ check_include_file( "machine/soundcard.h" HAVE_MACHINE_SOUNDCARD_H )
check_include_file( "malloc.h" HAVE_MALLOC_H )
check_include_file( "memory.h" HAVE_MEMORY_H )
check_include_file( "mntent.h" HAVE_MNTENT_H )
+check_include_file( "sys/mntent.h" HAVE_SYS_MNTENT_H )
check_include_file( "ndir.h" HAVE_NDIR_H )
check_include_file( "netinet/in.h" HAVE_NETINET_IN_H )
check_include_file( "net/if.h" HAVE_NET_IF_H )
@@ -229,7 +257,7 @@ check_include_file( "sys/dir.h" HAVE_SYS_DIR_H )
check_include_file( "sys/filio.h" HAVE_SYS_FILIO_H )
check_include_file( "sys/mman.h" HAVE_SYS_MMAN_H )
check_include_file( "sys/mntent.h" HAVE_SYS_MNTENT_H )
-check_include_file( "sys/mnttab.h" HAVE_SYS_MNTTAB_H )
+check_include_files( "stdio.h;sys/mnttab.h" HAVE_SYS_MNTTAB_H )
check_include_file( "sys/mount.h" HAVE_SYS_MOUNT_H )
if( NOT HAVE_SYS_MOUNT_H )
find_path( SYS_MOUNT_PATH "sys/mount.h" )
@@ -249,9 +277,16 @@ check_include_file( "sys/ucred.h" HAVE_SYS_UCRED_H )
if( NOT HAVE_SYS_UCRED_H )
find_path( SYS_UCRED_PATH "sys/ucred.h" )
if( SYS_UCRED_PATH )
- set( HAVE_SYS_UCRED_H "1" )
+ set( HAVE_SYS_UCRED_H 1 )
endif( )
endif( )
+check_include_file( "ucred.h" HAVE_UCRED_H )
+if( NOT HAVE_UCRED_H )
+ find_path( UCRED_PATH "ucred.h" )
+ if( UCRED_PATH )
+ set( HAVE_UCRED_H 1 )
+ endif()
+endif()
check_include_file( "sys/xattr.h" HAVE_SYS_XATTR_H )
check_include_file( "termios.h" HAVE_TERMIOS_H )
check_include_file( "termio.h" HAVE_TERMIO_H )
@@ -318,7 +353,7 @@ check_function_exists( mkstemp HAVE_MKSTEMP )
check_symbol_exists( mkstemp "stdlib.h" HAVE_MKSTEMP_PROTO )
check_function_exists( mkstemps HAVE_MKSTEMPS )
-check_symbol_exists( mkstemps "stdlib.h" HAVE_MKSTEMPS_PROTO )
+check_symbol_exists( mkstemps "stdlib.h;unistd.h" HAVE_MKSTEMPS_PROTO )
check_function_exists( initgroups HAVE_INITGROUPS )
check_symbol_exists( initgroups "grp.h;unistd.h" HAVE_INITGROUPS_PROTO )
@@ -346,6 +381,9 @@ else ()
find_package( Backtrace )
if ( Backtrace_FOUND )
set ( HAVE_BACKTRACE 1 )
+ else ()
+ set ( Backtrace_LIBRARY "" )
+ set ( Backtrace_HEADER "" )
endif ()
endif ()
check_cxx_source_compiles( "#include <cxxabi.h>
@@ -393,6 +431,7 @@ endif( HAVE_GETMNTINFO )
check_function_exists( getnameinfo HAVE_GETNAMEINFO )
check_function_exists( getpagesize HAVE_GETPAGESIZE )
check_function_exists( getpeereid HAVE_GETPEEREID )
+check_function_exists( getpeerucred HAVE_GETPEERUCRED )
check_function_exists( getpeername HAVE_GETPEERNAME )
check_function_exists( getprotobyname_r HAVE_GETPROTOBYNAME_R )
check_function_exists( getpt HAVE_GETPT )
@@ -432,11 +471,20 @@ check_function_exists( __argz_count HAVE___ARGZ_COUNT )
check_function_exists( __argz_next HAVE___ARGZ_NEXT )
check_function_exists( __argz_stringify HAVE___ARGZ_STRINGIFY )
check_function_exists( sendfile HAVE_SENDFILE )
+set( SENDFILE_LIBRARIES "" )
+if( NOT HAVE_SENDFILE)
+ check_library_exists( sendfile sendfile "" HAVE_SENDFILE_LIB )
+ if( HAVE_SENDFILE_LIB )
+ set( HAVE_SENDFILE 1 )
+ set( SENDFILE_LIBRARIES sendfile )
+ endif( HAVE_SENDFILE_LIB )
+endif()
check_function_exists( rindex HAVE_RINDEX )
check_function_exists( putenv HAVE_PUTENV )
check_function_exists( poll HAVE_POLL )
check_function_exists( madvise HAVE_MADVISE )
check_function_exists( getgroups HAVE_GETGROUPS )
+check_symbol_exists( posix_fadvise "fcntl.h" HAVE_FADVISE )
check_function_exists( getcwd HAVE_GETCWD )
check_function_exists( dlerror HAVE_DLERROR )
if( NOT HAVE_DLERROR )
@@ -474,7 +522,13 @@ check_type_size( "unsigned long" SIZEOF_UNSIGNED_LONG )
set( CMAKE_EXTRA_INCLUDE_FILES "netdb.h" )
check_type_size( "struct addrinfo" STRUCT_ADDRINFO )
set( CMAKE_EXTRA_INCLUDE_FILES "netinet/in.h" )
-check_type_size( "struct sockaddr_in6" HAVE_STRUCT_SOCKADDR_IN6 )
+check_type_size( "struct sockaddr_in6" STRUCT_SOCKADDR_IN6 )
+check_struct_has_member( "struct sockaddr_in6" sin6_scope_id "sys/types.h;sys/socket.h;netinet/in.h" HAVE_STRUCT_SOCKADDR_IN6_SIN6_SCOPE_ID )
+check_struct_has_member( "struct sockaddr" sa_len "sys/types.h;sys/socket.h;netinet/in.h" HAVE_STRUCT_SOCKADDR_SA_LEN )
+check_struct_has_member( "struct sockaddr_un" sun_len "sys/types.h;sys/un.h" HAVE_STRUCT_SOCKADDR_UN_SUN_LEN )
+set( CMAKE_EXTRA_INCLUDE_FILES "sys/socket.h" )
+check_type_size( "struct ucred" STRUCT_UCRED )
+check_struct_has_member( "struct sockaddr_in" sin_len "sys/types.h;sys/socket.h;netinet/in.h" HAVE_STRUCT_SOCKADDR_IN_SIN_LEN )
unset( CMAKE_EXTRA_INCLUDE_FILES )
check_c_source_compiles("
@@ -520,6 +574,8 @@ endif( NOT HAVE_GOOD_GETADDRINFO )
# save CMAKE_REQUIRED_LIBRARIES
set( bak_CMAKE_REQUIRED_LIBRARIES ${CMAKE_REQUIRED_LIBRARIES} )
+check_symbol_exists( res_init "sys/types.h;netinet/in.h;arpa/nameser.h;resolv.h" HAVE_RES_INIT_PROTO )
+
set( CMAKE_REQUIRED_LIBRARIES resolv )
check_c_source_compiles("
#include <sys/types.h>
@@ -606,6 +662,7 @@ if( NOT HAVE_LIBDL )
set( HAVE_LIBDL 1 )
endif( HAVE_DLOPEN )
endif( NOT HAVE_LIBDL )
+check_library_exists( dld, dld_link "" HAVE_DLD )
##### check for magic ###########################
@@ -712,26 +769,29 @@ endif( WITH_LZMA )
##### check for pcsc ############################
-if( WITH_PCSC )
- find_path( PCSCLITE_INCLUDE_DIR pcsclite.h
- HINTS /usr/include/PCSC )
- find_library( PCSCLITE_LIBRARY NAMES pcsclite libpcsclite PCSC )
- if( PCSCLITE_LIBRARY AND PCSCLITE_INCLUDE_DIR )
- message( STATUS "Found PCSCLITE: ${PCSCLITE_LIBRARY}" )
- set( PCSCLITE_FOUND 1 )
- set( PCSCLITE_INCLUDE_DIRS ${PCSCLITE_INCLUDE_DIR} )
- set( PCSCLITE_LIBRARIES ${PCSCLITE_LIBRARY} )
- endif( PCSCLITE_LIBRARY AND PCSCLITE_INCLUDE_DIR )
+if( WITH_TDEHWLIB AND WITH_PCSC )
+ pkg_search_module( PCSCLITE libpcsclite )
+ if( NOT PCSCLITE_FOUND )
+ find_path( PCSCLITE_INCLUDE_DIR pcsclite.h
+ HINTS /usr/include/PCSC )
+ find_library( PCSCLITE_LIBRARY NAMES pcsclite libpcsclite PCSC )
+ if( PCSCLITE_LIBRARY AND PCSCLITE_INCLUDE_DIR )
+ message( STATUS "Found PCSCLITE: ${PCSCLITE_LIBRARY}" )
+ set( PCSCLITE_FOUND 1 )
+ set( PCSCLITE_INCLUDE_DIRS ${PCSCLITE_INCLUDE_DIR} )
+ set( PCSCLITE_LIBRARIES ${PCSCLITE_LIBRARY} )
+ endif( PCSCLITE_LIBRARY AND PCSCLITE_INCLUDE_DIR )
+ endif( NOT PCSCLITE_FOUND )
if( NOT PCSCLITE_FOUND )
tde_message_fatal( "PCSCLITE is requested, but not found on your system" )
endif( NOT PCSCLITE_FOUND )
set( HAVE_PCSC_SUPPORT 1 )
-endif( WITH_PCSC )
+endif( WITH_TDEHWLIB AND WITH_PCSC )
##### check for pkcs ############################
-if( WITH_PKCS )
+if( WITH_TDEHWLIB AND WITH_PKCS )
pkg_search_module( LIBPKCS11-HELPER libpkcs11-helper-1 )
if( NOT LIBPKCS11-HELPER_FOUND )
message(FATAL_ERROR "\nPKCS support was requested, but libpkcs11-helper-1 was not found on your system" )
@@ -753,7 +813,7 @@ endif( )
##### check for pkcs ############################
-if( WITH_CRYPTSETUP )
+if( WITH_TDEHWLIB AND WITH_CRYPTSETUP )
pkg_search_module( LIBCRYPTSETUP libcryptsetup )
if( NOT LIBCRYPTSETUP_FOUND )
find_library( LIBCRYPTSETUP_LIBRARY cryptsetup )
@@ -770,7 +830,7 @@ if( WITH_CRYPTSETUP )
check_c_source_compiles("
#include <stddef.h>
#include <libcryptsetup.h>
- int main(int argc, char *argv[]) { crypt_keyslot_info status = CRYPT_SLOT_INVALID; return 0; } "
+ int main(int argc, char *argv[]) { crypt_keyslot_info status = CRYPT_SLOT_ACTIVE; return 0; } "
HAVE_NEW_CRYPTSETUP )
check_c_source_compiles("
#include <stddef.h>
@@ -1129,9 +1189,9 @@ if( WITH_ELFICON )
if( NOT LIBR_FOUND )
message(FATAL_ERROR "\nelficon support was requested, but libr was not found on your system" )
endif( NOT LIBR_FOUND )
- if( NOT "${LIBR_VERSION}" STREQUAL "0.6.0" )
+ if( "${LIBR_VERSION}" VERSION_LESS "0.6" )
message(FATAL_ERROR "\nelficon support was requested, but the libr version on your system may not be compatible with TDE" )
- endif( NOT "${LIBR_VERSION}" STREQUAL "0.6.0" )
+ endif( "${LIBR_VERSION}" VERSION_LESS "0.6" )
set( HAVE_ELFICON 1 )
endif( )
@@ -1405,6 +1465,7 @@ add_subdirectory( kate )
add_subdirectory( tdecert )
tde_conditional_add_subdirectory( WITH_XRANDR tderandr )
add_subdirectory( tdehtml )
+add_subdirectory( tdemarkdown )
add_subdirectory( tdecmshell )
add_subdirectory( tdeconf_update )
add_subdirectory( tdewidgets )