summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cf1cb11a8..ecacb26a9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -981,7 +981,15 @@ endif( WITH_LIBBFD )
if( WITH_SSL )
pkg_search_module( SSL openssl )
if( NOT SSL_FOUND )
- message(FATAL_ERROR "\nSSL support are requested, but openssl is not found on your system" )
+ check_include_file( openssl/ssl.h HAVE_OPENSSL_H )
+ check_library_exists( ssl SSL_library_init "" HAVE_LIBSSL )
+ check_library_exists( crypto EVP_EncryptInit_ex "" HAVE_LIBCRYPTO )
+ if( HAVE_OPENSSL_H AND HAVE_LIBSSL AND HAVE_LIBCRYPTO )
+ set( SSL_FOUND 1 CACHE INTERNAL "" FORCE )
+ endif( HAVE_OPENSSL_H AND HAVE_LIBSSL AND HAVE_LIBCRYPTO )
+ endif( NOT SSL_FOUND )
+ if( NOT SSL_FOUND )
+ tde_message_fatal( "SSL support is requested, but openssl not found on your system" )
endif( NOT SSL_FOUND )
set( KSSL_HAVE_SSL 1 )
set( HAVE_SSL 1 )