summaryrefslogtreecommitdiffstats
path: root/kio/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kio/CMakeLists.txt')
-rw-r--r--kio/CMakeLists.txt71
1 files changed, 0 insertions, 71 deletions
diff --git a/kio/CMakeLists.txt b/kio/CMakeLists.txt
deleted file mode 100644
index cd2dfd80e..000000000
--- a/kio/CMakeLists.txt
+++ /dev/null
@@ -1,71 +0,0 @@
-#################################################
-#
-# (C) 2010 Serghei Amelian
-# serghei (DOT) amelian (AT) gmail.com
-#
-# Improvements and feedback are welcome
-#
-# This file is released under GPL >= 2
-#
-#################################################
-
-add_definitions(
- -D_LARGEFILE64_SOURCE=1
-)
-
-add_subdirectory( kssl )
-add_subdirectory( kio )
-add_subdirectory( bookmarks )
-add_subdirectory( kfile )
-add_subdirectory( pics )
-add_subdirectory( kioexec )
-add_subdirectory( httpfilter )
-add_subdirectory( misc )
-add_subdirectory( kpasswdserver )
-add_subdirectory( tests )
-
-include_directories(
- ${TQT_INCLUDE_DIRS}
-)
-
-link_directories(
- ${TQT_LIBRARY_DIRS}
- ${LIBR_LIBDIR}
-)
-
-
-##### other data ################################
-
-install( FILES magic DESTINATION ${MIME_INSTALL_DIR} )
-
-install( FILES
- application.desktop kurifilterplugin.desktop
- kcomprfilter.desktop kscan.desktop kdatatool.desktop
- kfileplugin.desktop tdecmodule.desktop
- DESTINATION ${SERVICETYPES_INSTALL_DIR} )
-
-install( FILES kioslave.upd DESTINATION ${KCONF_UPDATE_INSTALL_DIR} )
-install( PROGRAMS useragent.pl proxytype.pl DESTINATION ${KCONF_UPDATE_INSTALL_DIR} )
-install( FILES renamedlgplugin.desktop DESTINATION ${SERVICETYPES_INSTALL_DIR} )
-install( FILES kpasswdserver.desktop DESTINATION ${SERVICES_INSTALL_DIR}/kded )
-install( FILES data.protocol DESTINATION ${SERVICES_INSTALL_DIR} )
-
-
-if( HAVE_ELFICON )
- set( ELFICON_STATIC_LIB tdelficon-static )
-endif( HAVE_ELFICON )
-
-
-##### libkio ####################################
-
-set( target kio )
-
-configure_file( ${CMAKE_SOURCE_DIR}/cmake/modules/template_dummy_cpp.cmake dummy.cpp COPYONLY )
-
-tde_add_library( ${target} SHARED
- SOURCES ${CMAKE_CURRENT_BINARY_DIR}/dummy.cpp
- VERSION 4.2.0
- EMBED kssl-static kiocore-static tdesycoca-static kbookmarks-static kfile-static ${ELFICON_STATIC_LIB}
- LINK ltdlc-static tdeui-shared tdesu-shared tdewalletclient-shared ${LIBR_LIBRARIES}
- DESTINATION ${LIB_INSTALL_DIR}
-)