summaryrefslogtreecommitdiffstats
path: root/kio/misc/tdewalletd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kio/misc/tdewalletd/Makefile.am')
-rw-r--r--kio/misc/tdewalletd/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/kio/misc/tdewalletd/Makefile.am b/kio/misc/tdewalletd/Makefile.am
new file mode 100644
index 000000000..5d52fa810
--- /dev/null
+++ b/kio/misc/tdewalletd/Makefile.am
@@ -0,0 +1,35 @@
+# This file is part of the KDE libraries
+# Copyright (C) 2002 George Staikos <staikos@kde.org>
+
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Library General Public
+# License as published by the Free Software Foundation; either
+# version 2 of the License, or (at your option) any later version.
+
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+
+# You should have received a copy of the GNU Library General Public License
+# along with this library; see the file COPYING.LIB. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
+# Boston, MA 02110-1301, USA.
+
+INCLUDES= -I$(srcdir)/.. -I$(top_srcdir) -I$(top_srcdir)/tdewallet/backend -I$(top_builddir)/tdewallet/backend -I$(top_srcdir)/tdewallet/client -I$(top_builddir)/tdewallet/client $(all_includes)
+
+kde_module_LTLIBRARIES = kded_tdewalletd.la
+
+kded_tdewalletd_la_LDFLAGS = $(all_libraries) -module -avoid-version
+kded_tdewalletd_la_LIBADD = $(LIB_KIO) ../../../tdewallet/backend/libtdewalletbackend.la ../../../tdewallet/client/libtdewalletclient.la $(LIB_KDED) $(LIB_QT) $(top_builddir)/dcop/libDCOP.la $(LIB_TDECORE) $(LIB_TDEUI)
+kded_tdewalletd_la_SOURCES = tdewalletd.cpp tdewalletd.skel ktimeout.cpp tdewalletwizard.ui kbetterthankdialogbase.ui
+
+METASOURCES = AUTO
+
+noinst_HEADERS = tdewalletd.h ktimeout.h tdewalletwizard.ui.h
+
+services_DATA = tdewalletd.desktop
+servicesdir = $(kde_servicesdir)/kded
+
+tdewalletwizard.lo: tdewalletwizard.ui tdewalletwizard.ui.h
+kbetterthankdialogbase.lo: kbetterthankdialogbase.ui kbetterthankdialogbase.ui.h