summaryrefslogtreecommitdiffstats
path: root/tdeabc/formats/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tdeabc/formats/Makefile.am')
-rw-r--r--tdeabc/formats/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/tdeabc/formats/Makefile.am b/tdeabc/formats/Makefile.am
new file mode 100644
index 000000000..d769d88d7
--- /dev/null
+++ b/tdeabc/formats/Makefile.am
@@ -0,0 +1,22 @@
+INCLUDES = -I$(top_srcdir)/kabc -I$(top_builddir)/kabc $(all_includes)
+
+kde_module_LTLIBRARIES = kabcformat_binary.la
+
+kabcformat_binary_la_SOURCES = binaryformat.cpp
+kabcformat_binary_la_LDFLAGS = -module $(KDE_PLUGIN) $(KDE_RPATH) $(all_libraries) \
+ -no-undefined
+kabcformat_binary_la_LIBADD = $(LIB_KABC) $(LIB_QT) $(LIB_TDECORE)
+kabcformat_binary_la_COMPILE_FIRST = $(top_builddir)/tdeabc/addressee.h
+
+# these are the headers for your project
+noinst_HEADERS = binaryformat.h
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kabcformat_binary.pot
+
+linkdir = $(kde_datadir)/tdeabc/formats
+link_DATA = binary.desktop
+EXTRA_DIST = $(link_DATA)