summaryrefslogtreecommitdiffstats
path: root/tdeabc/plugins/evolution/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tdeabc/plugins/evolution/Makefile.am')
-rw-r--r--tdeabc/plugins/evolution/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/tdeabc/plugins/evolution/Makefile.am b/tdeabc/plugins/evolution/Makefile.am
new file mode 100644
index 000000000..2c22cf376
--- /dev/null
+++ b/tdeabc/plugins/evolution/Makefile.am
@@ -0,0 +1,19 @@
+INCLUDES = -I$(top_builddir)/kabc -I$(top_srcdir)/kabc $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = resourceevo.h dbwrapper.h
+
+kde_module_LTLIBRARIES = kabc_evo.la
+
+kabc_evo_la_SOURCES = dbwrapper.cpp resourceevo.cpp
+
+kabc_evo_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+kabc_evo_la_LIBADD = ../../../tdeabc/libkabc.la ../../../tdeui/libtdeui.la -ldb ../../../tdeabc/vcardparser/libvcards.la
+
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kabc_evolution.pot
+
+servicedir = $(kde_servicesdir)/tderesources/kabc
+service_DATA = evolution.desktop