summaryrefslogtreecommitdiffstats
path: root/tdeabc/plugins/sql/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tdeabc/plugins/sql/Makefile.am')
-rw-r--r--tdeabc/plugins/sql/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/tdeabc/plugins/sql/Makefile.am b/tdeabc/plugins/sql/Makefile.am
new file mode 100644
index 000000000..3fa3986ce
--- /dev/null
+++ b/tdeabc/plugins/sql/Makefile.am
@@ -0,0 +1,20 @@
+INCLUDES = -I$(top_srcdir)/kabc -I$(top_builddir)/kabc $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = resourcesql.h resourcesqlconfig.h
+
+kde_module_LTLIBRARIES = kabc_sql.la
+
+kabc_sql_la_SOURCES = resourcesql.cpp resourcesqlconfig.cpp
+
+kabc_sql_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+kabc_sql_la_LIBADD = ../../libkabc.la ../../../tdeui/libtdeui.la
+
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kabc_sql.pot
+
+linkdir = $(kde_datadir)/tderesources/contact
+link_DATA = sql.desktop
+EXTRA_DIST = $(link_DATA)