summaryrefslogtreecommitdiffstats
path: root/tdeabc/vcardparser/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tdeabc/vcardparser/CMakeLists.txt')
-rw-r--r--tdeabc/vcardparser/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tdeabc/vcardparser/CMakeLists.txt b/tdeabc/vcardparser/CMakeLists.txt
index e141d1f47..692b7829f 100644
--- a/tdeabc/vcardparser/CMakeLists.txt
+++ b/tdeabc/vcardparser/CMakeLists.txt
@@ -73,6 +73,12 @@ tde_add_check_executable( testread2
LINK ${TDEABC_TESTS_LINK}
)
+if( CMAKE_VERSION VERSION_LESS "2.8.4" )
+ if( NOT EXISTS "${CMAKE_CURRENT_BINARY_DIR}/tests" )
+ execute_process( COMMAND ln -s "${CMAKE_CURRENT_SOURCE_DIR}/tests" "${CMAKE_CURRENT_BINARY_DIR}/tests" )
+ endif( )
+endif()
+
add_test( NAME tdeabc/vcardparser/testread2 COMMAND testread2 WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}" )
# testread tests