summaryrefslogtreecommitdiffstats
path: root/tdehtml/css/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tdehtml/css/Makefile.am')
-rw-r--r--tdehtml/css/Makefile.am60
1 files changed, 60 insertions, 0 deletions
diff --git a/tdehtml/css/Makefile.am b/tdehtml/css/Makefile.am
new file mode 100644
index 000000000..6c43675ed
--- /dev/null
+++ b/tdehtml/css/Makefile.am
@@ -0,0 +1,60 @@
+# This file is part of the KDE libraries
+# Copyright (C) 1997 Martin Jones (mjones@kde.org)
+# (C) 1997 Torben Weis (weis@kde.org)
+
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Library General Public
+# License as published by the Free Software Foundation; either
+# version 2 of the License, or (at your option) any later version.
+
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+
+# You should have received a copy of the GNU Library General Public License
+# along with this library; see the file COPYING.LIB. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
+# Boston, MA 02110-1301, USA.
+
+KDE_CXXFLAGS = $(WOVERLOADED_VIRTUAL)
+
+YACC=bison
+
+noinst_LTLIBRARIES = libtdehtmlcss.la
+libtdehtmlcss_la_SOURCES = \
+ css_stylesheetimpl.cpp css_ruleimpl.cpp css_valueimpl.cpp css_base.cpp \
+ cssparser.cpp cssstyleselector.cpp csshelper.cpp parser.cpp \
+ css_renderstyledeclarationimpl.cpp
+
+#libtdehtmlcss_la_LDFLAGS = -no-undefined
+libtdehtmlcss_la_METASOURCES = AUTO
+
+noinst_HEADERS = \
+ css_extensionsimpl.h css_stylesheetimpl.h cssparser.h \
+ css_ruleimpl.h css_valueimpl.h css_base.h \
+ cssstyleselector.h csshelper.h parser.h \
+ css_renderstyledeclarationimpl.h
+
+INCLUDES = -I$(top_srcdir)/kimgio -I$(top_srcdir)/kio -I$(top_srcdir)/dcop \
+ -I$(top_srcdir)/tdehtml -I$(top_srcdir)/libltdl -I$(top_srcdir) \
+ -I$(top_srcdir)/tdewallet/client -I$(top_srcdir)/tdeutils \
+ $(all_includes)
+
+cssdir = $(kde_datadir)/tdehtml/css
+css_DATA = html4.css quirks.css
+
+SRCDOC_DEST=$(kde_htmldir)/en/tdelibs/tdehtml
+
+EXTRA_DIST = parser.y
+
+parser: $(srcdir)/parser.y
+ cd $(srcdir); \
+ $(YACC) -v -d -p cssyy parser.y && mv parser.tab.c parser.cpp; \
+ if test -f parser.tab.h; then \
+ if cmp -s parser.tab.h parser.h; then rm -f parser.tab.h; \
+ else mv parser.tab.h parser.h; fi \
+ else :; fi
+
+.PHONY: parser
+