summaryrefslogtreecommitdiffstats
path: root/tdeioslave/gzip/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tdeioslave/gzip/CMakeLists.txt')
-rw-r--r--tdeioslave/gzip/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/tdeioslave/gzip/CMakeLists.txt b/tdeioslave/gzip/CMakeLists.txt
new file mode 100644
index 000000000..d08fc7e64
--- /dev/null
+++ b/tdeioslave/gzip/CMakeLists.txt
@@ -0,0 +1,41 @@
+#################################################
+#
+# (C) 2010 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_BINARY_DIR}/tdecore
+ ${CMAKE_SOURCE_DIR}/tdecore
+ ${CMAKE_SOURCE_DIR}/tdeio/tdeio
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES kgzipfilter.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+
+
+##### kgzipfilter ###############################
+
+set( target kgzipfilter )
+
+set( ${target}_SRCS
+ kgzipfilter.cpp
+)
+
+tde_add_kpart( ${target} AUTOMOC
+ SOURCES ${${target}_SRCS}
+ LINK tdeio-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)