summaryrefslogtreecommitdiffstats
path: root/tdespell2/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tdespell2/Makefile.am')
-rw-r--r--tdespell2/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/tdespell2/Makefile.am b/tdespell2/Makefile.am
new file mode 100644
index 000000000..00ee8a81d
--- /dev/null
+++ b/tdespell2/Makefile.am
@@ -0,0 +1,24 @@
+SUBDIRS = . ui tests plugins
+METASOURCES = AUTO
+
+noinst_LTLIBRARIES = libtdespell2base.la
+
+AM_CPPFLAGS = -DKDE_NO_COMPAT -DQT_NO_COMPAT -I$(top_srcdir)/tdeutils $(all_includes)
+
+tdespell2baseincludedir = $(includedir)/tdespell2
+
+tdespell2baseinclude_HEADERS = settings.h filter.h \
+ dictionary.h broker.h \
+ backgroundchecker.h defaultdictionary.h
+
+libtdespell2base_la_SOURCES = settings.cpp broker.cpp \
+ client.cpp filter.cpp backgroundchecker.cpp \
+ backgroundthread.cpp backgroundengine.cpp \
+ defaultdictionary.cpp
+
+libtdespell2base_la_LDFLAGS = -no-undefined $(all_libraries)
+
+servicetype_DATA = tdespellclient.desktop
+servicetypedir = $(kde_servicetypesdir)
+
+include $(top_srcdir)/admin/Doxyfile.am