summaryrefslogtreecommitdiffstats
path: root/tdespell2/plugins/aspell/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tdespell2/plugins/aspell/CMakeLists.txt')
-rw-r--r--tdespell2/plugins/aspell/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/tdespell2/plugins/aspell/CMakeLists.txt b/tdespell2/plugins/aspell/CMakeLists.txt
new file mode 100644
index 000000000..9ae66d01b
--- /dev/null
+++ b/tdespell2/plugins/aspell/CMakeLists.txt
@@ -0,0 +1,44 @@
+#################################################
+#
+# (C) 2010 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/tdecore
+ ${CMAKE_SOURCE_DIR}/tdespell2
+ ${CMAKE_SOURCE_DIR}/tdecore
+ ${ASPELL_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${ASPELL_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES tdespell_aspell.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+
+
+#### tdespell_aspell ##############################
+
+set( target tdespell_aspell )
+
+set( ${target}_SRCS
+ tdespell_aspellclient.cpp tdespell_aspelldict.cpp
+)
+
+tde_add_kpart( ${target} SHARED AUTOMOC
+ SOURCES ${${target}_SRCS}
+ LINK tdespell2-shared ${ASPELL_LIBRARIES}
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)