summaryrefslogtreecommitdiffstats
path: root/akode_artsplugin/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commite2de64d6f1beb9e492daf5b886e19933c1fa41dd (patch)
tree9047cf9e6b5c43878d5bf82660adae77ceee097a /akode_artsplugin/Makefile.am
downloadtdemultimedia-e2de64d6f1beb9e492daf5b886e19933c1fa41dd.tar.gz
tdemultimedia-e2de64d6f1beb9e492daf5b886e19933c1fa41dd.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdemultimedia@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'akode_artsplugin/Makefile.am')
-rw-r--r--akode_artsplugin/Makefile.am46
1 files changed, 46 insertions, 0 deletions
diff --git a/akode_artsplugin/Makefile.am b/akode_artsplugin/Makefile.am
new file mode 100644
index 00000000..230a6a01
--- /dev/null
+++ b/akode_artsplugin/Makefile.am
@@ -0,0 +1,46 @@
+INCLUDES= $(akode_includes) -I$(kde_includes)/arts $(all_includes)
+
+noinst_HEADERS = akodePlayObject_impl.h
+
+lib_LTLIBRARIES = libarts_akode.la
+
+libarts_akode_la_SOURCES = akodearts.cc akodePlayObject_impl.cpp \
+ akodeMPCPlayObject_impl.cpp akodeMPEGPlayObject_impl.cpp \
+ akodeFFMPEGPlayObject_impl.cpp akodeXiphPlayObject_impl.cpp \
+ akodeVorbisStreamPlayObject_impl.cpp akodeSpeexStreamPlayObject_impl.cpp
+libarts_akode_la_LDFLAGS = $(all_libraries) -module -no-undefined
+libarts_akode_la_LIBADD = $(akode_libs) -lkmedia2_idl -lsoundserver_idl -lartsflow
+libarts_akode_la_METASOURCES = AUTO
+libarts_akode_la_COMPILE_FIRST = akodearts.h
+
+$(srcdir)/akodePlayObject_impl.cpp: akodearts.h
+akodearts.mcopclass: akodearts.h
+akodearts.mcoptype: akodearts.h
+akodearts.cc akodearts.h: $(srcdir)/akodearts.idl
+ $(MCOPIDL) -t $(INCLUDES) $(srcdir)/akodearts.idl
+
+mcoptypedir = $(libdir)/mcop
+mcoptype_DATA = akodearts.mcoptype akodearts.mcopclass
+
+if include_akode_mpeg
+AKODE_MPEG=akodeMPEGPlayObject.mcopclass
+endif
+
+if include_akode_mpc
+AKODE_MPC=akodeMPCPlayObject.mcopclass
+endif
+
+if include_akode_xiph
+AKODE_XIPH=akodeXiphPlayObject.mcopclass akodeVorbisStreamPlayObject.mcopclass akodeSpeexStreamPlayObject.mcopclass
+endif
+
+if include_akode_ffmpeg
+AKODE_FFMPEG=akodeFFMPEGPlayObject.mcopclass
+endif
+
+mcopclassdir = $(libdir)/mcop
+mcopclass_DATA = akodePlayObject.mcopclass \
+ $(AKODE_MPC) $(AKODE_MPEG) $(AKODE_XIPH) $(AKODE_FFMPEG)
+
+CLEANFILES=akodearts.h akodearts.cc akodearts.mcopclass akodearts.mcoptype
+