summaryrefslogtreecommitdiffstats
path: root/kfile-plugins/ogg/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-10-28 15:59:28 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-10-28 15:59:28 +0000
commite775ea5d1bf610d735420e4b6c898367e2c6f0cb (patch)
tree8f13880562466148f77f83e503b6acbd5389b8c6 /kfile-plugins/ogg/Makefile.am
parent9f3b0a38068b96b7cdcabd563809efe6646f7fd6 (diff)
downloadtdemultimedia-e775ea5d1bf610d735420e4b6c898367e2c6f0cb.tar.gz
tdemultimedia-e775ea5d1bf610d735420e4b6c898367e2c6f0cb.zip
Pass assitional linker flags to kdemultimedia kfile-plugins modules to satisfy new direct DSO linking requirements
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdemultimedia@1261181 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kfile-plugins/ogg/Makefile.am')
-rw-r--r--kfile-plugins/ogg/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/kfile-plugins/ogg/Makefile.am b/kfile-plugins/ogg/Makefile.am
index d10bfeb9..ee4f19b7 100644
--- a/kfile-plugins/ogg/Makefile.am
+++ b/kfile-plugins/ogg/Makefile.am
@@ -9,7 +9,7 @@ noinst_HEADERS = kfile_ogg.h
kde_module_LTLIBRARIES = kfile_ogg.la
kfile_ogg_la_SOURCES = kfile_ogg.cpp vcedit.c
-kfile_ogg_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+kfile_ogg_la_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_KDECORE) $(LIB_KDEUI) -lkdefx $(LIB_KIO) -lktexteditor -module $(KDE_PLUGIN)
kfile_ogg_la_LIBADD = $(LIB_KIO) -logg -lvorbis -lvorbisfile
# let automoc handle all of the meta source files (moc)