summaryrefslogtreecommitdiffstats
path: root/kioslave/audiocd/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commite2de64d6f1beb9e492daf5b886e19933c1fa41dd (patch)
tree9047cf9e6b5c43878d5bf82660adae77ceee097a /kioslave/audiocd/Makefile.am
downloadtdemultimedia-e2de64d6f1beb9e492daf5b886e19933c1fa41dd.tar.gz
tdemultimedia-e2de64d6f1beb9e492daf5b886e19933c1fa41dd.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdemultimedia@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kioslave/audiocd/Makefile.am')
-rw-r--r--kioslave/audiocd/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/kioslave/audiocd/Makefile.am b/kioslave/audiocd/Makefile.am
new file mode 100644
index 00000000..736828e1
--- /dev/null
+++ b/kioslave/audiocd/Makefile.am
@@ -0,0 +1,33 @@
+if include_kcm_audiocd
+AUDIO_CD_SUBDIRS = kcmaudiocd
+endif
+SUBDIRS = plugins $(AUDIO_CD_SUBDIRS)
+
+INCLUDES = -I$(top_srcdir)/libkcddb \
+ -I$(top_builddir)/libkcddb $(all_includes) \
+ -I$(top_srcdir)/kscd $(all_includes) \
+ -I$(srcdir)/plugins $(all_includes)
+
+KDE_CXXFLAGS=$(ENABLE_PERMISSIVE_FLAG)
+
+kde_module_LTLIBRARIES = kio_audiocd.la
+
+kio_audiocd_la_SOURCES = audiocd.cpp
+
+kio_audiocd_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+
+kio_audiocd_la_LIBADD = ./plugins/libaudiocdplugins.la $(LIB_KIO) $(CDPARANOIA_LIBS) $(top_builddir)/libkcddb/libkcddb.la $(top_builddir)/kscd/libkcompactdisc.la
+
+noinst_HEADERS = audiocd.h
+
+protocoldir = $(kde_servicesdir)
+protocol_DATA = audiocd.protocol
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/kio_audiocd.pot
+
+updatedir = $(kde_datadir)/kconf_update
+update_DATA = audiocd.upd
+update_SCRIPTS = upgrade-metadata.sh
+
+audiocd.lo: ../../libkcddb/configbase.h