summaryrefslogtreecommitdiffstats
path: root/mpeglib/example/tplay/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2017-03-26 15:58:46 +0200
committerSlávek Banko <slavek.banko@axis.cz>2017-03-26 15:58:46 +0200
commit8b12682035e2ae92a29a9ce12abc5fbcf38b1192 (patch)
tree1cc5c3fe9ef3b23557fc4e9e507fd0d23d007160 /mpeglib/example/tplay/CMakeLists.txt
parent250d713ff809fa943f614459009d1160e269dcef (diff)
downloadtdemultimedia-8b12682035e2ae92a29a9ce12abc5fbcf38b1192.tar.gz
tdemultimedia-8b12682035e2ae92a29a9ce12abc5fbcf38b1192.zip
Initial cmake conversion
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'mpeglib/example/tplay/CMakeLists.txt')
-rw-r--r--mpeglib/example/tplay/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/mpeglib/example/tplay/CMakeLists.txt b/mpeglib/example/tplay/CMakeLists.txt
new file mode 100644
index 00000000..06f25e99
--- /dev/null
+++ b/mpeglib/example/tplay/CMakeLists.txt
@@ -0,0 +1,31 @@
+#################################################
+#
+# (C) 2017 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${ARTS_LIBRARY_DIRS}
+)
+
+
+##### tplay (executable) ########################
+
+tde_add_executable( tplay
+ SOURCES tplay.cpp
+ LINK mpeg-shared
+)