summaryrefslogtreecommitdiffstats
path: root/mpeglib/lib/input/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2017-03-26 15:58:46 +0200
committerSlávek Banko <slavek.banko@axis.cz>2017-03-26 15:58:46 +0200
commit8b12682035e2ae92a29a9ce12abc5fbcf38b1192 (patch)
tree1cc5c3fe9ef3b23557fc4e9e507fd0d23d007160 /mpeglib/lib/input/CMakeLists.txt
parent250d713ff809fa943f614459009d1160e269dcef (diff)
downloadtdemultimedia-8b12682035e2ae92a29a9ce12abc5fbcf38b1192.tar.gz
tdemultimedia-8b12682035e2ae92a29a9ce12abc5fbcf38b1192.zip
Initial cmake conversion
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'mpeglib/lib/input/CMakeLists.txt')
-rw-r--r--mpeglib/lib/input/CMakeLists.txt51
1 files changed, 51 insertions, 0 deletions
diff --git a/mpeglib/lib/input/CMakeLists.txt b/mpeglib/lib/input/CMakeLists.txt
new file mode 100644
index 00000000..37e1f539
--- /dev/null
+++ b/mpeglib/lib/input/CMakeLists.txt
@@ -0,0 +1,51 @@
+#################################################
+#
+# (C) 2017 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### mpeg_input (library) ######################
+
+tde_add_library( mpeg_input STATIC_PIC
+ SOURCES
+ inputStream.cpp fileInputStream.cpp
+ inputPlugin.cpp
+ cdromToc.cpp cdromRawAccess.cpp
+ cdromInputStream.cpp
+ bufferInputStream.cpp
+ simpleRingBuffer.cpp
+ cdromAccess.cpp inputDetector.cpp
+ httpInputStream.cpp
+ threadSafeInputStream.cpp
+ cddaInputStream.cpp
+ fileAccessWrapper.cpp
+)
+
+
+##### other data ################################
+
+install(
+ FILES
+ inputStream.h fileInputStream.h
+ inputPlugin.h
+ cdromInputStream.h bufferInputStream.h
+ inputDetector.h httpInputStream.h
+ threadSafeInputStream.h cddaInputStream.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/mpeglib/input
+)