summaryrefslogtreecommitdiffstats
path: root/mpeglib_artsplug/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2017-03-26 15:58:46 +0200
committerSlávek Banko <slavek.banko@axis.cz>2017-03-26 15:58:46 +0200
commit8b12682035e2ae92a29a9ce12abc5fbcf38b1192 (patch)
tree1cc5c3fe9ef3b23557fc4e9e507fd0d23d007160 /mpeglib_artsplug/CMakeLists.txt
parent250d713ff809fa943f614459009d1160e269dcef (diff)
downloadtdemultimedia-8b12682035e2ae92a29a9ce12abc5fbcf38b1192.tar.gz
tdemultimedia-8b12682035e2ae92a29a9ce12abc5fbcf38b1192.zip
Initial cmake conversion
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'mpeglib_artsplug/CMakeLists.txt')
-rw-r--r--mpeglib_artsplug/CMakeLists.txt109
1 files changed, 109 insertions, 0 deletions
diff --git a/mpeglib_artsplug/CMakeLists.txt b/mpeglib_artsplug/CMakeLists.txt
new file mode 100644
index 00000000..61ad25d4
--- /dev/null
+++ b/mpeglib_artsplug/CMakeLists.txt
@@ -0,0 +1,109 @@
+#################################################
+#
+# (C) 2017 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/mpeglib/lib
+ ${CMAKE_BINARY_DIR}/mpeglib/lib
+ ${CMAKE_BINARY_DIR}
+ ${ARTS_INCLUDE_DIRS}
+ ${ARTSC_INCLUDE_DIRS}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${ARTS_LIBRARY_DIRS}
+)
+
+
+##### arts_mpeglib (library) ####################
+
+tde_add_library( arts_mpeglib SHARED
+ SOURCES
+ decoderBaseObject.cc
+ splayPlayObject.cc
+ decoderBaseObject_impl.cpp
+ oggPlayObject_impl.cpp
+ mpgPlayObject_impl.cpp
+ wavPlayObject_impl.cpp
+ mp3PlayObject_impl.cpp
+ cddaPlayObject_impl.cpp
+ vcdPlayObject_impl.cpp
+ nullPlayObject_impl.cpp
+ RELEASE ${MPEGLIB_VERSION}
+ VERSION ${MPEGLIB_SO_VERSION}
+ LINK mpeg-shared ${ARTS_LIBRARIES}
+ DESTINATION ${LIB_INSTALL_DIR}
+)
+
+add_custom_command(
+ OUTPUT
+ decoderBaseObject.cc decoderBaseObject.h
+ COMMAND ${ARTS_MCOPIDL_EXECUTABLE}
+ -I${ARTS_INCLUDEDIR} ${CMAKE_CURRENT_SOURCE_DIR}/decoderBaseObject.idl
+ DEPENDS decoderBaseObject.idl
+)
+
+
+##### arts_splay (library) ######################
+
+tde_add_library( arts_splay SHARED
+ SOURCES
+ splayPlayObject.cc
+ splayPlayObject_impl.cpp
+ VERSION 0.0.0
+ LINK mpeg-shared ${ARTS_LIBRARIES}
+ DESTINATION ${LIB_INSTALL_DIR}
+)
+
+add_custom_command(
+ OUTPUT
+ splayPlayObject.cc splayPlayObject.h
+ COMMAND ${ARTS_MCOPIDL_EXECUTABLE}
+ -I${ARTS_INCLUDEDIR} ${CMAKE_CURRENT_SOURCE_DIR}/splayPlayObject.idl
+ DEPENDS splayPlayObject.idl
+)
+
+
+##### mpeglibartsplay (executable) ##############
+
+tde_add_executable( mpeglibartsplay
+ SOURCES mpeglibartsplay.cpp
+ LINK mcop kmedia2_idl soundserver_idl artsflow_idl ${ARTSC_LIBRARIES}
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### other data ################################
+
+install(
+ FILES
+ decoderBaseObject_impl.h
+ ${CMAKE_CURRENT_BINARY_DIR}/decoderBaseObject.h
+ decoderBaseObject.idl
+ splayPlayObject_impl.h
+ ${CMAKE_CURRENT_BINARY_DIR}/splayPlayObject.h
+ splayPlayObject.idl
+ DESTINATION ${INCLUDE_INSTALL_DIR}/mpeglib_artsplug
+)
+
+install(
+ FILES
+ WAVPlayObject.mcopclass
+ MP3PlayObject.mcopclass
+ OGGPlayObject.mcopclass
+ CDDAPlayObject.mcopclass
+ NULLPlayObject.mcopclass
+ SplayPlayObject.mcopclass
+ DESTINATION ${LIB_INSTALL_DIR}/mcop
+)