summaryrefslogtreecommitdiffstats
path: root/tdefile-plugins/au/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2017-03-26 15:58:46 +0200
committerSlávek Banko <slavek.banko@axis.cz>2017-03-26 15:59:04 +0200
commitefcdd889254fc98314dd48854d50e90aa21e53c0 (patch)
tree5dc7034c23a5a18ca31d90225137f5eeaec809c4 /tdefile-plugins/au/CMakeLists.txt
parent25709e498d5832125f5f584bd10e3c66d05ec5ee (diff)
downloadtdemultimedia-efcdd889254fc98314dd48854d50e90aa21e53c0.tar.gz
tdemultimedia-efcdd889254fc98314dd48854d50e90aa21e53c0.zip
Initial cmake conversion
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 8b12682035e2ae92a29a9ce12abc5fbcf38b1192)
Diffstat (limited to 'tdefile-plugins/au/CMakeLists.txt')
-rw-r--r--tdefile-plugins/au/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/tdefile-plugins/au/CMakeLists.txt b/tdefile-plugins/au/CMakeLists.txt
new file mode 100644
index 00000000..669e348a
--- /dev/null
+++ b/tdefile-plugins/au/CMakeLists.txt
@@ -0,0 +1,38 @@
+#################################################
+#
+# (C) 2017 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### tdefile_au (module) #######################
+
+tde_add_kpart( tdefile_au AUTOMOC
+ SOURCES
+ tdefile_au.cpp
+ LINK
+ DCOP-shared tdecore-shared tdeui-shared tdefx-shared tdeio-shared
+ tdetexteditor-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### other data ################################
+
+install( FILES tdefile_au.desktop DESTINATION ${SERVICES_INSTALL_DIR} )