summaryrefslogtreecommitdiffstats
path: root/tdefile-plugins/mpeg/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:32 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:32 -0600
commit793cf2dff35dffe3ec4c7b24252947dde758a1b2 (patch)
tree7d9972d99ed281a36418ae9f5fc128e3c951532c /tdefile-plugins/mpeg/Makefile.am
parent04f764aaf273340e1d5811d4216dd8127cacc5db (diff)
downloadtdemultimedia-793cf2dff35dffe3ec4c7b24252947dde758a1b2.tar.gz
tdemultimedia-793cf2dff35dffe3ec4c7b24252947dde758a1b2.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdefile-plugins/mpeg/Makefile.am')
-rw-r--r--tdefile-plugins/mpeg/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/tdefile-plugins/mpeg/Makefile.am b/tdefile-plugins/mpeg/Makefile.am
new file mode 100644
index 00000000..63fd9460
--- /dev/null
+++ b/tdefile-plugins/mpeg/Makefile.am
@@ -0,0 +1,22 @@
+## Makefile.am for mpeg file meta info plugin
+
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = tdefile_mpeg.h
+
+kde_module_LTLIBRARIES = tdefile_mpeg.la
+
+tdefile_mpeg_la_SOURCES = tdefile_mpeg.cpp
+tdefile_mpeg_la_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_KIO) -ltdetexteditor -module $(KDE_PLUGIN)
+tdefile_mpeg_la_LIBADD = $(LIB_KIO)
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) tdefile_mpeg.cpp -o $(podir)/tdefile_mpeg.pot
+
+services_DATA = tdefile_mpeg.desktop
+servicesdir = $(kde_servicesdir)