summaryrefslogtreecommitdiffstats
path: root/arts/modules/effects/freeverb/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'arts/modules/effects/freeverb/CMakeLists.txt')
-rw-r--r--arts/modules/effects/freeverb/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/arts/modules/effects/freeverb/CMakeLists.txt b/arts/modules/effects/freeverb/CMakeLists.txt
new file mode 100644
index 00000000..a634252d
--- /dev/null
+++ b/arts/modules/effects/freeverb/CMakeLists.txt
@@ -0,0 +1,34 @@
+#################################################
+#
+# (C) 2017 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/arts/gui/common
+ ${CMAKE_BINARY_DIR}/arts/midi
+ ${CMAKE_BINARY_DIR}/arts/modules
+ ${CMAKE_BINARY_DIR}/arts/runtime
+ ${CMAKE_BINARY_DIR}
+ ${ARTS_INCLUDE_DIRS}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${ARTS_LIBRARY_DIRS}
+)
+
+
+##### freeverb (library) ########################
+
+tde_add_library( freeverb STATIC_PIC
+ SOURCES allpass.cpp comb.cpp revmodel.cpp
+)