summaryrefslogtreecommitdiffstats
path: root/kfile-plugins/flac/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kfile-plugins/flac/Makefile.am')
-rw-r--r--kfile-plugins/flac/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/kfile-plugins/flac/Makefile.am b/kfile-plugins/flac/Makefile.am
new file mode 100644
index 00000000..bb3a08e3
--- /dev/null
+++ b/kfile-plugins/flac/Makefile.am
@@ -0,0 +1,22 @@
+## Makefile.am for FLAC file meta info plugin
+
+# set the include path for X, qt, KDE and TagLib
+INCLUDES = $(all_includes) $(taglib_includes)
+
+# these are the headers for your project
+noinst_HEADERS = kfile_flac.h
+
+kde_module_LTLIBRARIES = kfile_flac.la
+
+kfile_flac_la_SOURCES = kfile_flac.cpp
+kfile_flac_la_LDFLAGS = $(all_libraries) $(taglib_libs) -module $(KDE_PLUGIN)
+kfile_flac_la_LIBADD = $(LIB_KIO)
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) kfile_flac.cpp -o $(podir)/kfile_flac.pot
+
+services_DATA = kfile_flac.desktop
+servicesdir = $(kde_servicesdir)