summaryrefslogtreecommitdiffstats
path: root/kfile-plugins/ogg/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kfile-plugins/ogg/Makefile.am')
-rw-r--r--kfile-plugins/ogg/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/kfile-plugins/ogg/Makefile.am b/kfile-plugins/ogg/Makefile.am
new file mode 100644
index 00000000..d10bfeb9
--- /dev/null
+++ b/kfile-plugins/ogg/Makefile.am
@@ -0,0 +1,22 @@
+## Makefile.am for ogg/vorbis file meta info plugin
+
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = kfile_ogg.h
+
+kde_module_LTLIBRARIES = kfile_ogg.la
+
+kfile_ogg_la_SOURCES = kfile_ogg.cpp vcedit.c
+kfile_ogg_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+kfile_ogg_la_LIBADD = $(LIB_KIO) -logg -lvorbis -lvorbisfile
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) kfile_ogg.cpp -o $(podir)/kfile_ogg.pot
+
+services_DATA = kfile_ogg.desktop
+servicesdir = $(kde_servicesdir)