summaryrefslogtreecommitdiffstats
path: root/kioslave/audiocd/kcmaudiocd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kioslave/audiocd/kcmaudiocd/Makefile.am')
-rw-r--r--kioslave/audiocd/kcmaudiocd/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/kioslave/audiocd/kcmaudiocd/Makefile.am b/kioslave/audiocd/kcmaudiocd/Makefile.am
new file mode 100644
index 00000000..962c3fa0
--- /dev/null
+++ b/kioslave/audiocd/kcmaudiocd/Makefile.am
@@ -0,0 +1,17 @@
+kde_module_LTLIBRARIES = kcm_audiocd.la
+
+kcm_audiocd_la_SOURCES = audiocdconfig.ui kcmaudiocd.cpp
+
+kcm_audiocd_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -module
+kcm_audiocd_la_LIBADD = ../plugins/libaudiocdplugins.la $(LIB_KDEUI)
+
+INCLUDES = -I$(srcdir)/../plugins -I$(top_srcdir)/libkcddb $(all_includes)
+
+kcm_audiocd_la_METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kcmaudiocd.pot
+
+xdg_apps_DATA = audiocd.desktop
+
+audiocdconfig.cpp: audiocdconfig.h