summaryrefslogtreecommitdiffstats
path: root/krec/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'krec/Makefile.am')
-rw-r--r--krec/Makefile.am14
1 files changed, 9 insertions, 5 deletions
diff --git a/krec/Makefile.am b/krec/Makefile.am
index d205d622..cbce157d 100644
--- a/krec/Makefile.am
+++ b/krec/Makefile.am
@@ -42,7 +42,7 @@ krec_la_SOURCES = \
main.cpp \
krecord.cpp
-krec_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+krec_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries) $(LIB_QT) -lDCOP $(LIB_KDECORE) $(LIB_KDEUI) -lkdefx $(LIB_KIO) -lktexteditor -lmcop -lartsflow_idl -lkmedia2_idl -lsoundserver_idl -L../arts/modules/effects -lartsmoduleseffects
krec_la_LIBADD = \
lib_krec_common.la \
$(top_builddir)/arts/gui/kde/libartsgui_kde.la \
@@ -50,11 +50,13 @@ krec_la_LIBADD = \
-lartskde $(LIBDL) $(LIB_KIO) $(LIB_KDEUI) $(LIB_KUTILS)
kcm_krec_la_SOURCES = krecconfigure.cpp
-kcm_krec_la_LDFLAGS = -module -avoid-version -no-undefined $(all_libraries)
+kcm_krec_la_LDFLAGS = -module -avoid-version -no-undefined $(all_libraries) $(LIB_QT) -lDCOP $(LIB_KDECORE) $(LIB_KDEUI) -lkdefx $(LIB_KIO) -lktexteditor -lmcop -lartsflow_idl -lkmedia2_idl -lsoundserver_idl -L../arts/modules/effects -lartsmoduleseffects
+
kcm_krec_la_LIBADD = lib_krec_common.la $(LIB_KUTILS)
kcm_krec_files_la_SOURCES = krecconfig_files.cpp
-kcm_krec_files_la_LDFLAGS = -module -avoid-version -no-undefined $(all_libraries)
+kcm_krec_files_la_LDFLAGS = -module -avoid-version -no-undefined $(all_libraries) $(LIB_QT) -lDCOP $(LIB_KDECORE) $(LIB_KDEUI) -lkdefx $(LIB_KIO) -lktexteditor -lmcop -lartsflow_idl -lkmedia2_idl -lsoundserver_idl -L../arts/modules/effects -lartsmoduleseffects
+
kcm_krec_files_la_LIBADD = lib_krec_common.la $(LIB_KUTILS)
lib_krec_common_la_SOURCES = \
@@ -62,11 +64,13 @@ lib_krec_common_la_SOURCES = \
krecexport_template.cpp \
krecconfig_fileswidget.cpp
-lib_krec_common_la_LDFLAGS = -module -avoid-version -no-undefined $(all_libraries)
+lib_krec_common_la_LDFLAGS = -module -avoid-version -no-undefined $(all_libraries) $(LIB_QT) -lDCOP $(LIB_KDECORE) $(LIB_KDEUI) -lkdefx $(LIB_KIO) -lktexteditor -lmcop -lartsflow_idl -lkmedia2_idl -lsoundserver_idl -L../arts/modules/effects -lartsmoduleseffects
+
lib_krec_common_la_LIBADD = $(LIB_KDEUI) $(LIB_KIO)
libkrecexport_wave_la_SOURCES = krecexport_wave.cpp
-libkrecexport_wave_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+libkrecexport_wave_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN) $(LIB_QT) -lDCOP $(LIB_KDECORE) $(LIB_KDEUI) -lkdefx $(LIB_KIO) -lktexteditor -lmcop -lartsflow_idl -lkmedia2_idl -lsoundserver_idl -L../arts/modules/effects -lartsmoduleseffects
+
libkrecexport_wave_la_LIBADD = lib_krec_common.la
rcdir = $(kde_datadir)/krec