summaryrefslogtreecommitdiffstats
path: root/kscd/libwm/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kscd/libwm/CMakeLists.txt')
-rw-r--r--kscd/libwm/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/kscd/libwm/CMakeLists.txt b/kscd/libwm/CMakeLists.txt
new file mode 100644
index 00000000..e40ac76e
--- /dev/null
+++ b/kscd/libwm/CMakeLists.txt
@@ -0,0 +1,38 @@
+#################################################
+#
+# (C) 2017 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include( ConfigureChecks.cmake )
+
+add_subdirectory( audio )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+)
+
+
+##### workman (library) #########################
+
+tde_add_library( workman STATIC_PIC
+ SOURCES
+ cddb.c cdinfo.c cdrom.c wm_helpers.c cdtext.c
+ database.c index.c scsi.c cdda.c plat_linux_cdda.c plat_sun_cdda.c
+ plat_aix.c plat_bsd386.c plat_freebsd.c plat_hpux.c plat_irix.c
+ plat_linux.c plat_svr4.c plat_ultrix.c plat_news.c plat_openbsd.c
+ plat_osf1.c plat_sun.c plat_scor5.c
+ drv_sony.c drv_toshiba.c
+ EMBED
+ workmanaudio-static
+ LINK
+ pthread
+)