summaryrefslogtreecommitdiffstats
path: root/mpeglib/example/cddaplay/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'mpeglib/example/cddaplay/CMakeLists.txt')
-rw-r--r--mpeglib/example/cddaplay/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/mpeglib/example/cddaplay/CMakeLists.txt b/mpeglib/example/cddaplay/CMakeLists.txt
new file mode 100644
index 00000000..1ffecb0e
--- /dev/null
+++ b/mpeglib/example/cddaplay/CMakeLists.txt
@@ -0,0 +1,31 @@
+#################################################
+#
+# (C) 2017 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${ARTS_LIBRARY_DIRS}
+)
+
+
+##### cddaplay (executable) #####################
+
+tde_add_executable( cddaplay
+ SOURCES cddaplay.cpp
+ LINK mpeg-shared
+)