summaryrefslogtreecommitdiffstats
path: root/mpeglib/example/splay/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'mpeglib/example/splay/CMakeLists.txt')
-rw-r--r--mpeglib/example/splay/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/mpeglib/example/splay/CMakeLists.txt b/mpeglib/example/splay/CMakeLists.txt
new file mode 100644
index 00000000..d7292f79
--- /dev/null
+++ b/mpeglib/example/splay/CMakeLists.txt
@@ -0,0 +1,39 @@
+#################################################
+#
+# (C) 2017 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${ARTS_LIBRARY_DIRS}
+)
+
+
+##### splay (executable) ########################
+
+tde_add_executable( splay
+ SOURCES splay.cpp
+ LINK mpeg-shared
+)
+
+
+##### mp3framing (executable) ###################
+
+tde_add_executable( mp3framing
+ SOURCES mp3framing.cpp
+ LINK mpeg-shared
+)