summaryrefslogtreecommitdiffstats
path: root/mpeglib/example/yaf/yaftplay/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'mpeglib/example/yaf/yaftplay/CMakeLists.txt')
-rw-r--r--mpeglib/example/yaf/yaftplay/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/mpeglib/example/yaf/yaftplay/CMakeLists.txt b/mpeglib/example/yaf/yaftplay/CMakeLists.txt
new file mode 100644
index 00000000..eeb05ea8
--- /dev/null
+++ b/mpeglib/example/yaf/yaftplay/CMakeLists.txt
@@ -0,0 +1,32 @@
+#################################################
+#
+# (C) 2017 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${ARTS_LIBRARY_DIRS}
+)
+
+
+##### yaf-tplay (executable) ####################
+
+tde_add_executable( yaf-tplay
+ SOURCES tplay_control.cpp
+ LINK
+ yafcore-shared yafxplayer-shared
+ mpeg-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)