summaryrefslogtreecommitdiffstats
path: root/mpeglib/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mpeglib/lib/Makefile.am')
-rw-r--r--mpeglib/lib/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/mpeglib/lib/Makefile.am b/mpeglib/lib/Makefile.am
new file mode 100644
index 00000000..74a7d181
--- /dev/null
+++ b/mpeglib/lib/Makefile.am
@@ -0,0 +1,36 @@
+# player - Makefile.am
+
+SUBDIRS = frame util input output decoder \
+ splay oggvorbis mpegplay mpgplayer tplay yuv
+
+MMXFILES =
+
+
+EXTRA_DIST = README
+
+
+THIS_EXTRALIBS = mpgplayer/libmpgplayer.la \
+ mpegplay/libmpegplay.la \
+ splay/libsplay.la \
+ oggvorbis/liboggvorbisbase.la \
+ tplay/libtplay.la \
+ decoder/libdecoder.la \
+ output/liboutput.la \
+ input/libinput.la \
+ util/libutil.la \
+ frame/libframe.la \
+ yuv/libyuvPlugin.la
+
+
+
+lib_LTLIBRARIES = libmpeg.la
+
+libmpeg_la_SOURCES = dummy.cpp
+
+
+libmpeg_la_LDFLAGS = $(all_libraries) \
+ -release $(THIS_LIB_VERSION)
+
+
+libmpeg_la_LIBADD = $(THIS_EXTRALIBS) $(MMXFILES) \
+ $(THIS_LIB_LIBS)