summaryrefslogtreecommitdiffstats
path: root/mpeglib/lib/util/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'mpeglib/lib/util/CMakeLists.txt')
-rw-r--r--mpeglib/lib/util/CMakeLists.txt48
1 files changed, 48 insertions, 0 deletions
diff --git a/mpeglib/lib/util/CMakeLists.txt b/mpeglib/lib/util/CMakeLists.txt
new file mode 100644
index 00000000..877688c1
--- /dev/null
+++ b/mpeglib/lib/util/CMakeLists.txt
@@ -0,0 +1,48 @@
+#################################################
+#
+# (C) 2017 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( abstract )
+add_subdirectory( audio )
+add_subdirectory( file )
+add_subdirectory( mmx )
+add_subdirectory( render )
+
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### mpeg_util (library) #######################
+
+tde_add_library( mpeg_util STATIC_PIC
+ SOURCES
+ timeStamp.cpp
+ timeStampArray.cpp
+ dynBuffer.cpp syncClock.cpp
+ syncClockMPEG.cpp timeWrapper.cpp
+)
+
+
+##### other data ################################
+
+install(
+ FILES
+ timeStamp.h dynBuffer.h
+ timeStampArray.h syncClock.h timeWrapper.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/mpeglib/util
+)