summaryrefslogtreecommitdiffstats
path: root/mpeglib/lib/util/abstract/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'mpeglib/lib/util/abstract/CMakeLists.txt')
-rw-r--r--mpeglib/lib/util/abstract/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/mpeglib/lib/util/abstract/CMakeLists.txt b/mpeglib/lib/util/abstract/CMakeLists.txt
new file mode 100644
index 00000000..38cdd152
--- /dev/null
+++ b/mpeglib/lib/util/abstract/CMakeLists.txt
@@ -0,0 +1,37 @@
+#################################################
+#
+# (C) 2017 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### mpeg_utilabstract (library) ###############
+
+tde_add_library( mpeg_utilabstract STATIC_PIC
+ SOURCES
+ abs_thread_sdl.cpp threadQueue.cpp
+)
+
+
+##### other data ################################
+
+install(
+ FILES
+ abs_thread.h threadQueue.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/mpeglib/util/abstract
+)