summaryrefslogtreecommitdiffstats
path: root/mpeglib/lib/util/render/x11/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'mpeglib/lib/util/render/x11/CMakeLists.txt')
-rw-r--r--mpeglib/lib/util/render/x11/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/mpeglib/lib/util/render/x11/CMakeLists.txt b/mpeglib/lib/util/render/x11/CMakeLists.txt
new file mode 100644
index 00000000..7c36e325
--- /dev/null
+++ b/mpeglib/lib/util/render/x11/CMakeLists.txt
@@ -0,0 +1,31 @@
+#################################################
+#
+# (C) 2017 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### mpeg_utilrenderx11 (library) ##############
+
+tde_add_library( mpeg_utilrenderx11 STATIC_PIC
+ SOURCES
+ initDisplay.cpp
+ imageDeskX11.cpp
+ imageDGAFull.cpp imageXVDesk.cpp
+ x11Surface.cpp
+)