summaryrefslogtreecommitdiffstats
path: root/noatun/modules/dcopiface/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'noatun/modules/dcopiface/CMakeLists.txt')
-rw-r--r--noatun/modules/dcopiface/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/noatun/modules/dcopiface/CMakeLists.txt b/noatun/modules/dcopiface/CMakeLists.txt
new file mode 100644
index 00000000..8947fd00
--- /dev/null
+++ b/noatun/modules/dcopiface/CMakeLists.txt
@@ -0,0 +1,41 @@
+#################################################
+#
+# (C) 2017 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/noatun/library
+ ${CMAKE_BINARY_DIR}/noatun/library
+ ${ARTS_INCLUDE_DIRS}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${ARTS_LIBRARY_DIRS}
+)
+
+
+##### noatun_dcopiface (module) #################
+
+tde_add_kpart( noatun_dcopiface AUTOMOC
+ SOURCES
+ dcopiface.cpp dcopiface.skel
+ LINK
+ tdeio-shared noatun-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### other data ################################
+
+install( FILES dcopiface.plugin DESTINATION ${DATA_INSTALL_DIR}/noatun )