summaryrefslogtreecommitdiffstats
path: root/noatun/modules/excellent/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'noatun/modules/excellent/CMakeLists.txt')
-rw-r--r--noatun/modules/excellent/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/noatun/modules/excellent/CMakeLists.txt b/noatun/modules/excellent/CMakeLists.txt
new file mode 100644
index 00000000..d4202bae
--- /dev/null
+++ b/noatun/modules/excellent/CMakeLists.txt
@@ -0,0 +1,44 @@
+#################################################
+#
+# (C) 2017 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/noatun/library
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${ARTS_LIBRARY_DIRS}
+)
+
+
+##### noatun_excellent (module) #################
+
+tde_add_kpart( noatun_excellent AUTOMOC
+ SOURCES
+ noatunui.cpp userinterface.cpp
+ LINK
+ tdeio-shared noatun-shared noatuncontrols-shared
+ mcop qtmcop kmedia2_idl soundserver_idl
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### other data ################################
+
+install(
+ FILES
+ excellent.plugin excellentui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/noatun
+)