summaryrefslogtreecommitdiffstats
path: root/noatun/modules/keyz/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'noatun/modules/keyz/Makefile.am')
-rw-r--r--noatun/modules/keyz/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/noatun/modules/keyz/Makefile.am b/noatun/modules/keyz/Makefile.am
new file mode 100644
index 00000000..61c9f1bd
--- /dev/null
+++ b/noatun/modules/keyz/Makefile.am
@@ -0,0 +1,14 @@
+INCLUDES= -I$(top_srcdir)/noatun/library -I$(kde_includes)/arts $(all_includes)
+kde_module_LTLIBRARIES = noatun_keyz.la
+
+noatun_keyz_la_SOURCES = keyz.cpp
+
+noatun_keyz_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+noatun_keyz_la_LIBADD = $(LIB_KFILE) $(top_builddir)/noatun/library/libnoatun.la
+
+noatun_keyz_la_METASOURCES = AUTO
+
+noinst_HEADERS = keyz.h
+
+noatun_modules_keyz_DATA = keyz.plugin
+noatun_modules_keyzdir = $(kde_datadir)/noatun