summaryrefslogtreecommitdiffstats
path: root/noatun/modules/metatag/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'noatun/modules/metatag/Makefile.am')
-rw-r--r--noatun/modules/metatag/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/noatun/modules/metatag/Makefile.am b/noatun/modules/metatag/Makefile.am
new file mode 100644
index 00000000..330e9f34
--- /dev/null
+++ b/noatun/modules/metatag/Makefile.am
@@ -0,0 +1,15 @@
+INCLUDES= -I$(top_srcdir)/noatun/library -I$(kde_includes)/arts $(all_includes)
+kde_module_LTLIBRARIES = noatun_metatag.la
+
+noatun_metatag_la_SOURCES = metatag.cpp edit.cpp
+
+noatun_metatag_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+noatun_metatag_la_LIBADD = $(LIB_KIO) $(top_builddir)/noatun/library/libnoatun.la \
+ $(top_builddir)/noatun/library/noatuntags/libnoatuntags.la
+
+noatun_metatag_la_METASOURCES = AUTO
+
+noinst_HEADERS = metatag.h edit.h
+
+noatun_modules_metatag_DATA = metatag.plugin
+noatun_modules_metatagdir = $(kde_datadir)/noatun