summaryrefslogtreecommitdiffstats
path: root/noatun/modules/monoscope/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'noatun/modules/monoscope/Makefile.am')
-rw-r--r--noatun/modules/monoscope/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/noatun/modules/monoscope/Makefile.am b/noatun/modules/monoscope/Makefile.am
new file mode 100644
index 00000000..55c58a05
--- /dev/null
+++ b/noatun/modules/monoscope/Makefile.am
@@ -0,0 +1,16 @@
+INCLUDES= -I$(top_srcdir)/noatun/library $(all_includes)
+kde_module_LTLIBRARIES = noatun_monoscope.la
+
+noatun_monoscope_la_SOURCES = monoscope.cpp
+#prefs.cpp
+
+noatun_monoscope_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+noatun_monoscope_la_LIBADD = $(LIB_KFILE) $(top_builddir)/noatun/library/libnoatun.la -lm
+
+noatun_monoscope_la_METASOURCES = AUTO
+
+noinst_HEADERS = monoscope.h
+#prefs.h
+
+noatun_modules_monoscope_DATA = monoscope.plugin
+noatun_modules_monoscopedir = $(kde_datadir)/noatun