summaryrefslogtreecommitdiffstats
path: root/noatun/modules/net/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'noatun/modules/net/CMakeLists.txt')
-rw-r--r--noatun/modules/net/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/noatun/modules/net/CMakeLists.txt b/noatun/modules/net/CMakeLists.txt
new file mode 100644
index 00000000..662baa5f
--- /dev/null
+++ b/noatun/modules/net/CMakeLists.txt
@@ -0,0 +1,40 @@
+#################################################
+#
+# (C) 2017 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/noatun/library
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${ARTS_LIBRARY_DIRS}
+)
+
+
+##### noatun_net (module) #######################
+
+tde_add_kpart( noatun_net AUTOMOC
+ SOURCES
+ net.cpp
+ LINK
+ tdeio-shared noatun-shared
+ mcop qtmcop kmedia2_idl soundserver_idl
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### other data ################################
+
+install( FILES net.plugin DESTINATION ${DATA_INSTALL_DIR}/noatun )